I have Azure API management - premium deployed with two locations West & East.
I want to Disable the East location by running the below Azure cli
az apim update --name apimx --resource-group rg --set additionalLocations[0].disableGateway=true
It throws the following error
doesn't have permission to perform action 'join/action' on the linked scope(s) /subscription/..../subnets/APIM
Why does it try to update the subnet and what kind of update will happen?