Laravel 7 composer autoload error caused by PHP UOPZ extension

Viewed 130

I have my Laravel 7 app uploaded on VPS server running on the subdomain. Everything is fine, index.php opens for the subdomain, I have generated an app key and installed composer packages. Then I got 500 internal error. Here is a screenshot enter image description here

The error has something to do with composer autoload.

Here is the list of things I tried doing.

php artisan cache:clear composer update Deleting vendor folder and running composer install

1 Answers

I think I have found the solution. I had tried all sorts of things like deleting composer.lock or vendor and running composer update/install and it did not help.

Finally disabling PHP UOPZ extension solved the problem.

For Ubuntu 16.04 phpdismod oupz systemctl reload apache2

Related