Config Processing error circle-ci when I do build

Viewed 906

I'm facing a problem with Config Processing error (circle-ci).

Material that I use

  • Aws cloud front
  • aws s3
  • circle-ci

situation

I did set up on AWS and added value to Environment Variables (circle-ci ). I did commit on git and build on circle-ci and an error occurs and I could not get out this error.

This is my repo

error

 bin/sh -eo pipefail
     ERROR IN CONFIG FILE:
     [#/jobs] 8 schema violations found
     Any string key is allowed as job name.
     1. [#/jobs/deploy-to-aws-cloudfront] 0 subschemas matched instead of one
     |   1. [#/jobs/deploy-to-aws-cloudfront] only 1 subschema matches out of 2
     |   |   1. [#/jobs/deploy-to-aws-cloudfront] 3 schema violations found
     |   |   |   1. [#/jobs/deploy-to-aws-cloudfront] required key [steps] not found
     |   |   |   2. [#/jobs/deploy-to-aws-cloudfront/docker/0] 2 schema violations found
     |   |   |   |   1. [#/jobs/deploy-to-aws-cloudfront/docker/0] extraneous key [steps] is not permitted
     |   |   |   |   |   Permitted keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - name
     |   |   |   |   |     - entrypoint
     |   |   |   |   |     - command
     |   |   |   |   |     - user
     |   |   |   |   |     - environment
     |   |   |   |   |     - aws_auth
     |   |   |   |   |     - auth
     |   |   |   |   |   Passed keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - working_directory
     |   |   |   |   |     - steps
     |   |   |   |   2. [#/jobs/deploy-to-aws-cloudfront/docker/0] extraneous key [working_directory] is not permitted
     |   |   |   |   |   Permitted keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - name
     |   |   |   |   |     - entrypoint
     |   |   |   |   |     - command
     |   |   |   |   |     - user
     |   |   |   |   |     - environment
     |   |   |   |   |     - aws_auth
     |   |   |   |   |     - auth
     |   |   |   |   |   Passed keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - working_directory
     |   |   |   |   |     - steps
     |   2. [#/jobs/deploy-to-aws-cloudfront] expected type: String, found: Mapping
     |   |   Job may be a string reference to another job
     2. [#/jobs/deploy-to-aws-s3] 0 subschemas matched instead of one
     |   1. [#/jobs/deploy-to-aws-s3] only 1 subschema matches out of 2
     |   |   1. [#/jobs/deploy-to-aws-s3] 3 schema violations found
     |   |   |   1. [#/jobs/deploy-to-aws-s3] required key [steps] not found
     |   |   |   2. [#/jobs/deploy-to-aws-s3/docker/0] 2 schema violations found
     |   |   |   |   1. [#/jobs/deploy-to-aws-s3/docker/0] extraneous key [steps] is not permitted
     |   |   |   |   |   Permitted keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - name
     |   |   |   |   |     - entrypoint
     |   |   |   |   |     - command
     |   |   |   |   |     - user
     |   |   |   |   |     - environment
     |   |   |   |   |     - aws_auth
     |   |   |   |   |     - auth
     |   |   |   |   |   Passed keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - working_directory
     |   |   |   |   |     - steps
     |   |   |   |   2. [#/jobs/deploy-to-aws-s3/docker/0] extraneous key [working_directory] is not permitted
     |   |   |   |   |   Permitted keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - name
     |   |   |   |   |     - entrypoint
     |   |   |   |   |     - command
     |   |   |   |   |     - user
     |   |   |   |   |     - environment
     |   |   |   |   |     - aws_auth
     |   |   |   |   |     - auth
     |   |   |   |   |   Passed keys:
     |   |   |   |   |     - image
     |   |   |   |   |     - working_directory
     |   |   |   |   |     - steps
     |   2. [#/jobs/deploy-to-aws-s3] expected type: String, found: Mapping
     |   |   Job may be a string reference to another job
     
     -------
     Warning: This configuration was auto-generated to show you the message above.
     Don't rerun this job. Rerunning will have no effect.
    false
1 Answers
Related