Cassandra Reaper JMX_AUTH error, when using cassandra as backend storage?

Viewed 98

For the reaper-2.0.5 and cassandra-3.11.8 integration have made below changes:-

  1. In the cassandra-env.sh file have changed the value of variable LOCAL_JMX=no in line number-249.

  2. In line number-267 have changed the value for jmxremote.autheticate to false..

  3. Also commented the line number-283 which is used to provide jmxremote.password.file..

Other all variable for cassandra-reaper has set correctly. When I am starting the reaper service getting below errors

Caused by: come.fasterxml.jackson.databind.jsonMappingException: N/A (through reference chain: io.cassnadrareaper.ReaperApplicationConfiguration["jmxAuth"])->io.cassandrareaper.core.JmxCredentials$Builder["username"])

This seems even though I have disabled remote jmx authentication on cassandra; but still cassandra-reaper is expecting to provide JMX_AUTH_USERNAME and password.. Pls let me know how to resolve this issue??

1 Answers

You could try to set CASSANDRA_JMX_AUTH: false in reaper deployment.

Related