I'm trying to run a local cluster with this command:
storm local target/myjar.jar com.app.MyMainClass
Storm responds with this error:
WARN o.a.s.s.o.a.z.ClientCnxn - Session 0x0 for server localhost/<unresolved>:2000, unexpected error, closing socket connection and attempting reconnect
java.lang.IllegalArgumentException: Unable to canonicalize address localhost/<unresolved>:2000 because it's not resolvable
at org.apache.storm.shade.org.apache.zookeeper.SaslServerPrincipal.getServerPrincipal(SaslServerPrincipal.java:65) ~[storm-shaded-deps-2.2.0.jar:2.2.0]
at org.apache.storm.shade.org.apache.zookeeper.SaslServerPrincipal.getServerPrincipal(SaslServerPrincipal.java:41) ~[storm-shaded-deps-2.2.0.jar:2.2.0]
at org.apache.storm.shade.org.apache.zookeeper.ClientCnxn$SendThread.startConnect(ClientCnxn.java:1001) ~[storm-shaded-deps-2.2.0.jar:2.2.0]
at org.apache.storm.shade.org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1060) [storm-shaded-deps-2.2.0.jar:2.2.0]
The topology will submit fine when using a dockerized setup with zookeeper, nimbus, and supervisor containers. I'm using a homebrew installation of storm when running locally, but so far I can't find any similar issues online.