Recently we moved our spark Jobs to Kerberized cluster. Some of our Spark jobs pull data from another cluster which is not Kerberized yet. When spark job tries to connect to Hive of unKerberized clusters we got Error.
20/08/11 19:40:10 WARN metastore: set_ugi() not successful, Likely cause: new client talking to old server. Continuing without it.
org.apache.thrift.transport.TTransportException
20/08/11 19:40:10 WARN RetryingMetaStoreClient: MetaStoreClient lost connection. Attempting to reconnect (1 of 1) after 1s. getAllFunctions
org.apache.thrift.transport.TTransportException
Full-stack trace https://pastebin.com/Fvs290Fs