WSL2 cannot write ".log" file

Viewed 713

Okay this is a weird one, I recently switched from wsl1 to wsl2 (I should not do it :-(), to try docker.

So I backed everything and converted my devenv inside wsl to version 2.

With wsl2 I've had multiple permission problems which I mostly solved, but now it seems that the user "www-data" cannot create/write to ".log" files.

sudo -u www-data touch /mnt/d/work/logs/api.error.log

Fails (no such file or directory), but

sudo -u www-data touch /mnt/d/work/logs/api.error.txt

works without any problem (I tried multiple file extensions (.png, .test, .lock, .lck,....)

Why can a ".log" file not be created, whats the problem, is it a Windows problem or an Ubuntu/WSL2 Problem?

Windows 10 - 64 bit Version 2004 - Build 19041.388 Ubuntu/WSL2 - 18.04.4 LTS - Bionic

0 Answers
Related