JBoss EAP Container Fails to Start

Viewed 496

When I run the following Dockerfile, the container responds with an error and exits.

If I comment out COPY, the container starts with no error.

Do I need to configure something else to get the container to start and deploy the app?

Dockerfile:

FROM registry.redhat.io/jboss-eap-7/eap73-openjdk11-openshift-rhel8
COPY containerPocApp.war /opt/eap/standalone/data/content/containerPocApp.war
EXPOSE 8080

Error:

ERROR Error applying /tmp/cli-configuration-script-1595016439.cli CLI script.

00:00:00,000 INFO [org.jboss.modules] (CLI command executor) JBoss Modules version 1.10.0.Final-redhat-00001

Cannot start embedded server: WFLYEMB0022: Cannot invoke 'start' on embedded process: WFLYSRV0231: Could not read or create the server UUID in file: /opt/eap/standalone/data/kernel/process-uuid: /opt/eap/standalone/data/kernel
1 Answers

I think you need to add r/w permission for Jboss dir to the root group , the error indicates a r/w permission errors

try to add this to your Dockerfile

USER root
RUN chgrp -R 0 $JBOSS_HOME && chmod -R g+rw $JBOSS_HOME
Related