I have installed WireGuard on Windows server 2017. When I activate the tunnel through the client application (manager) all works fine. After I restart the computer, WireGuard fails to start automatically. The log contains the following error:
[tun] [wg0] Unable to create Wintun interface: Error registering rings: Error listing NDIS interfaces: no interfaces found
I can explicitly/manually activate the tunnel through the client application but I need the tunnel to start automatically if the machine restarts.
I have it installed in other Windows Server 2017 machines and on those machines WireGuard starts automatically when the system boots.
I would appreciate your help in addressing the problem of WireGuard auto start when the machine boots.