- I have a VM that houses both the SQL server and the IIS server.
- My IIS server has an application pool that run a .NET web application.
- This application pool identity is domain\account1
- My application web.config connection string has "Trusted_Connection=True" and Data Source=NAME\INSTANCE01
- My SQL server has "SQL Server and Window Authetnication mode" enabled. The account domain\account1 is added to the database security login.
- I can RDP into this VM using domain\account1 and I can connect to the Database via SMS using Window Authentication and connecting to NAME\INSTANCE01
- I verify that only have one domain on our AD and DC.
However, when I tried to log in my web application, the .NET error trace shows it fails at the login. Upon looking at the Database's log I see the error below. The error seems to indicate the Identity user (domain\account1) I'm using in my .NET application cannot log into the database due to this error.
This has been baffling because I researched around and found this error only occur if you connect from an outside domain but I don't know why it shows this in my case.
I tried and look into my AD but it looks like it is up because if it isn't I would not have been able to RDP into the VM using domain\account1 in the first place.
Any guidance that help me narrow down the cause are much welcomed.
