Recently my staging website going down by a 525 error.
Which mean that origin server do not trust Cloudflare, but it's been 6 months that I have not touch anything between Cloud Run and Cloudflare.
To make it work again I had to put Cloudflare in Full (Not strict) Mode.
Do you think this problem has been caused by a Cloudflare certrificate renew ? If it's the case I need to put Cloudflare Origin CA on Cloud Run, but I can't find anything about this.
Hope you can help me, thanks !