The from address does not match a verified Sender Identity. Mail cannot be sent until this error is resolved

Viewed 5383

I follow this link:

https://sendgrid.com/docs/ui/sending-email/sender-verification

In my sendgrid account the from_email is set as verifie Single sender authentication, but when i send email verifications in my localhost, i still receive the same message : The from address does not match a verified Sender Identity

my config:

EMAIL_HOST = 'smtp.sendgrid.net'
EMAIL_HOST_USER = 'apikey'
EMAIL_HOST_PASSWORD = 'your api generate password'
EMAIL_PORT = 587
EMAIL_USE_TLS = True
1 Answers

You need to add another line to your config containing the verified sender's address:

DEFAULT_FROM_EMAIL = 'you@domain.com'

Related