ArangoDB unable to initialize RocksDB engine: IO error: While lock file

Viewed 674

FATAL [fe3df] {startup} unable to initialize RocksDB engine: IO error: While lock file: /var/lib/arangodb3/engine-rocksdb/LOCK: Resource temporarily unavailable; Maybe your filesystem doesn't provide required features? (Cifs? NFS?)

I was trying to setup an arangodb cluster consisted of three node and the above error occurred when I typed "arangod" at my Centos terminal.

1 Answers

You probably meant to type arangosh to get a shell to your running installation?

If you re-invoke arangod this will try to start another database server, that may not have access to the database files.

Please note that the database has certain requirements to the file system its started on; on Linux Ext4 is the best fit for this. The filesystem may not be transparent if you're using WSL or the like.

Related