Redis - Wrong signature trying to load DB from file

Viewed 2259

I'm using Redis image to run the docker container but when start I got this error:

redis-server    | 1:M 11 May 2020 09:31:25.479 # Wrong signature trying to load DB from file
redis-server    | 1:M 11 May 2020 09:31:25.479 # Fatal error loading the DB: Invalid argument. Exiting.

Btw I'm running it on AWS EC2. Any thought about this? Thanks in advance.

1 Answers

Following the suggestion mentioned on this page solved this issue: https://github.com/redis/redis/issues/6032

  1. Find the dump.rdb:

sudo find / -name *.rdb

  1. Delete the file, for example:

sudo rm /var/lib/redis/dump.rdb

Related