Devstack installation failed with error message "XXX: no process found"

Viewed 3367

I'm trying to install Devstack on VMware cloud. After starting to run ./stack.sh, installation is failed with following error message.

+lib/cinder:create_volume_types:531        openstack --os-region-name=RegionOne volume type create --property volume_backend_name=lvmdriver-1 lvmdriver-1
Internal Server Error (HTTP 500)
+lib/cinder:create_volume_types:1          exit_trap
+./stack.sh:exit_trap:489                  local r=1
++./stack.sh:exit_trap:490                  jobs -p
+./stack.sh:exit_trap:490                  jobs=
+./stack.sh:exit_trap:493                  [[ -n '' ]]
+./stack.sh:exit_trap:499                  '[' -f /tmp/tmp.Y95KBJPvp8 ']'
+./stack.sh:exit_trap:500                  rm /tmp/tmp.Y95KBJPvp8
+./stack.sh:exit_trap:504                  kill_spinner
+./stack.sh:kill_spinner:399               '[' '!' -z '' ']'
+./stack.sh:exit_trap:506                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:507                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:509                  type -p generate-subunit
+./stack.sh:exit_trap:510                  generate-subunit 1588897469 720 fail
+./stack.sh:exit_trap:512                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:515                  /usr/bin/python3.6 /opt/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2020-05-08-003630.txt for details
nova-compute: no process found
neutron-dhcp-agent: no process found
neutron-l3-agent: no process found
neutron-metadata-agent: no process found
neutron-openvswitch-agent: no process found
+./stack.sh:exit_trap:524                  exit 1

It looks like HTTP 500 error is the primary issue. But ping to HOST_IP works very well so I can't figure out the cause.

[[local|localrc]]

# Credentials
ADMIN_PASSWORD=devstack
MYSQL_PASSWORD=devstack
RABBIT_PASSWORD=devstack
SERVICE_PASSWORD=devstack
SERVICE_TOKEN=token

# Network Address
HOST_IP=(...)

This is devstack's log file.

nova-compute Guru Meditation Report
===================================

19171
killall -e -USR2 nova-compute
-----------------------------

*** Failed to run 'killall -e -USR2 nova-compute': Command 'killall -e -USR2 nova-compute' returned non-zero exit status 1.
guru meditation report in nova-compute log

neutron-dhcp-agent Guru Meditation Report
=========================================

7758
killall -e -USR2 neutron-dhcp-agent
-----------------------------------

*** Failed to run 'killall -e -USR2 neutron-dhcp-agent': Command 'killall -e -USR2 neutron-dhcp-agent' returned non-zero exit status 1.
guru meditation report in neutron-dhcp-agent log

neutron-l3-agent Guru Meditation Report
=======================================

8482
killall -e -USR2 neutron-l3-agent
---------------------------------

*** Failed to run 'killall -e -USR2 neutron-l3-agent': Command 'killall -e -USR2 neutron-l3-agent' returned non-zero exit status 1.
guru meditation report in neutron-l3-agent log

neutron-linuxbridge-agent Guru Meditation Report
================================================

Skipping as neutron-linuxbridge-agent does not appear to be running

neutron-metadata-agent Guru Meditation Report
=============================================

9103
9719
9720
killall -e -USR2 neutron-metadata-agent
---------------------------------------

*** Failed to run 'killall -e -USR2 neutron-metadata-agent': Command 'killall -e -USR2 neutron-metadata-agent' returned non-zero exit status 1.
guru meditation report in neutron-metadata-agent log

neutron-openvswitch-agent Guru Meditation Report
================================================

7127
killall -e -USR2 neutron-openvswitch-agent
------------------------------------------

*** Failed to run 'killall -e -USR2 neutron-openvswitch-agent': Command 'killall -e -USR2 neutron-openvswitch-agent' returned non-zero exit status 1.
guru meditation report in neutron-openvswitch-agent log

cinder-volume Guru Meditation Report
====================================

21971
killall -e -USR2 cinder-volume
------------------------------

guru meditation report in cinder-volume log

What is the problem?

2 Answers

I get this log

'''
sudo systemctl enable devstack@sl-api.service
Created symlink /etc/systemd/system/multi-user.target.wants/devstack@sl-api.service → /etc/systemd/system/devstack@sl-api.service.
++functions-common:_run_under_systemd:1531  sudo systemctl start devstack@sl-api.service
Job for devstack@sl-api.service failed because the control process exited with error code.
See "systemctl status devstack@sl-api.service" and "journalctl -xe" for details.
+functions-common:_run_under_systemd:1     exit_trap
+./stack.sh:exit_trap:489                  local r=1
++./stack.sh:exit_trap:490                  jobs -p
+./stack.sh:exit_trap:490                  jobs=
+./stack.sh:exit_trap:493                  [[ -n '' ]]
+./stack.sh:exit_trap:499                  '[' -f /tmp/tmp.g8xjCU2yg2 ']'
+./stack.sh:exit_trap:500                  rm /tmp/tmp.g8xjCU2yg2
+./stack.sh:exit_trap:504                  kill_spinner
+./stack.sh:kill_spinner:399               '[' '!' -z '' ']'
+./stack.sh:exit_trap:506                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:507                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:509                  type -p generate-subunit
+./stack.sh:exit_trap:510                  generate-subunit 1593717952 1120 fail
+./stack.sh:exit_trap:512                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:515                  /usr/bin/python3.6 /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs
nova-compute: no process found
neutron-dhcp-agent: no process found
neutron-l3-agent: no process found
neutron-metadata-agent: no process found
neutron-openvswitch-agent: no process found
+./stack.sh:exit_trap:524                  exit 1

'''

and i resolve this by suing cd /usr/bin ls | grep uwsgi if file is here then use if you don't have it here then you can reinstall using apt-get install uwsgi or pip install uwsgi cd /usr/local/bin ln -s /usr/bin/uwsgi uwsgi

./unstack.sh ./stach.sh here we go.....

I got it to work. just do:

  • pip install uwsgi

in the stack user.

The same error code will reflect. But do not worry, it works. Just go to the http:IPaddress/dashboard

And you will see the openstack horizon dashboard. :)

Related