I have a particular SELECT * FROM DB query that pulls from a SQL view. However, it fails with an
error 17310: cannot complete query because it is in a kill state (LOG: exception_access_violation).
I've traced it down to a single column of information that is causing the issue. If I specify all other columns but this specific one, it works fine. If I pull the top 1000 records, including the bad column, it works fine. If I query that one, bad column but filter the results, it works fine.
I'm running SQL Server 2016 and have installed all cumulative updates (12). I'm at a loss for what's going on and any assistance is appreciated.