I'm trying to make reverse load balancer proxy server with nginX.
I created express server at 106.10.**.***:3000 and 106.10.**.***:4000
When I ran systemctl start nginx.service it returned error like
Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.
root@airbnb-api:/etc/nginx/sites-enabled# systemctl start nginx.service
so I tried systemctl status nginx.service which is on below
events { }
http {
upstream backend {
server 106.10.**.***:3000;
server 106.10.**.***:4000;
}
server {
location / {
proxy_pass http://backend;
}
}
}
ā nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-10-29 00:22:20 KST; 7s ago
Docs: man:nginx(8)
Process: 3634 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Oct 29 00:22:20 airbnb-api systemd[1]: Starting A high performance web server and a reverse proxy server...
Oct 29 00:22:20 airbnb-api nginx[3634]: nginx: [emerg] "events" directive is not allowed here in /etc/nginx/sites-enabled/myapp.conf:1
Oct 29 00:22:20 airbnb-api nginx[3634]: nginx: configuration file /etc/nginx/nginx.conf test failed
Oct 29 00:22:20 airbnb-api systemd[1]: nginx.service: Control process exited, code=exited status=1
Oct 29 00:22:20 airbnb-api systemd[1]: Failed to start A high performance web server and a reverse proxy server.
Oct 29 00:22:20 airbnb-api systemd[1]: nginx.service: Unit entered failed state.
Oct 29 00:22:20 airbnb-api systemd[1]: nginx.service: Failed with result 'exit-code'.
I've checked 106.10.**.***:3000 106.10.**.***:4000 and they worked well.
Noting returned when trying sudo lsof -i:80
both code returned to be successful
nginx -t -c /etc/nginx/sites-available/myapp.conf
nginx -t -c /etc/nginx/sites-enabled/myapp.conf