After an automatically triggered DB Backup, Our CloudSQL DB CPU usage is always up 100% after any client connects that DB. The steps to reproduce this issue is
- Stop all the services that connect to that DB
- Restart the DB
- Observe that CPU usage is 0% if no external client connect to the DB
- Use a desktop Postgres client to connect to DB
- The CPU usage going up to 100% within 2 min and even thus, the desktop Postgres client failed to connect to that DB (a connection timeout error)
We don't see any valuable info from the operation logs, and we find this issue after one specific DB auto-backup but it works fine before that backup.