redirect URI is not registered properly with DocuSign

Viewed 3397

i am running the DOCUSIGN example code "eg-03-node-auth-code-grant" to check how embedded signing works(at https://localhost:5000). So after the signing is complete i would want it to return to another app. I have my other app running at localhost:8080. In the Docusign developer sandbox account, i have added "https://localhost:8080/ds/callback" in the list of redirect URLs. When i test the embedded signing code now, it gives me an error saying "Redirect URI is not registered properly with docusign"

What I ideally want is to build a separate docusign app for a consent process. once the consent is done, it goes to my other application to complete the rest of the study. For now, i was testing out with the example code it it redirects to another app but it doesnt. Am I missing something? other than registering the redirect URI in the integration key page, is there any change i need to make in the demo code for embedded signing to make it work?

6 Answers

As said in support : "There are two primary causes of this error, either an incorrect URI is being passed to DocuSign, or a correct URI has not been registered for the integration key."

I had the same problem, so i realized that appUrl was http://localhost:8080/ds/callback, but should be http:localhost:8080. So you have to add too a Redirect URI of http://localhost:8080/ds/callback to your Integration Key in your eSignature Admin.

I hope i was clear and sorry for my bad english.

It's possible you're using incorrect environment, use account-d.docusign.com for Demo and account.docusign.com for Production when requesting for authorization code grant.

Another thing to check is the use of trailing slashes in app_url. While my case related to the PHP Quickstart, it's possible this affects the others as well.

My Quickstart application was installed to a subdirectory, at https://example.com/docusign/public/. So the redirect URI was set in the DocuSign dashboard as https://example.com/docusign/public/index.php?page=ds_callback - which is correct but I was still getting the "not registered properly" error.

It turns out that the app_url in /docusign/ds_config.php must not have a trailing slash, so

    'app_url' => 'https://example.com/docusign/public', // The url of the application.

works but

    'app_url' => 'https://example.com/docusign/public/', // The url of the application.

fails with this error.

You just need to add http://localhost:8080/login like the redirect URI in Docusign and you won't see the error message "The redirect URI is not registered properly with DocuSign" again. It's working for me.

Related