Due to error 0x80070057" The parameter is incorrect." SSIS job failed to run

Viewed 9436
2 Answers

SSIS solutions that have been used on SQL Server 2008 R2, must be migrated to work properly on 2016/2017. The XML structure of the ssis packages is completely different and I belive 2008 packages only was supported until 2012/2014.

The process of doing this is basicly.

  1. Install VS2017 and newest version of SSDT
  2. Open SSIS project and run migration wizard
  3. Solve migration conflicts
  4. Build and deploy

I'm posting here because I've struggled as well with this issue, but on my SCD and I believe this might help someone.

I managed to resolve it by removing the precision of my datetime2(7)by converting it to a DateTime before entering the SCD component.

You can also try to reduce your varchar type fields from eg 4000 to 200 if possible which will allow your flow to run successfully.

Good luck!

Related