Bigtable Client initialization stuck in Kubernetes container

Viewed 263

We are trying to run a Golang app on Kubernetes which talks to Bigtable. The application seems to be stuck at creating the client:

bigtableClient := bigtable.NewClient()

upon setting the log level to info using:

export GRPC_GO_LOG_SEVERITY_LEVEL="INFO"

the error message is like this:

WARNING: 2019/06/05 08:14:13 grpc: addrConn.createTransport failed to connect to {dns:///bigtable.googleapis.com:443 0  1}. Err :connection error: desc = "transport: Error while dialing dial tcp: address dns:///bigtable.googleapis.com:443: too many colons in address". Reconnecting...
WA

We tried using the Alpine docker image but doesn't seem to work. Has anybody faced this before?

1 Answers
Related