LinkedIn post inspector encountering server error on https URL

Viewed 4171

Inspecting a given URL in the LinkedIn post inspector returns the following ingestion feedback:

Error   We encountered a server error while trying to inspect the URL.

The URL redirect trail shows:

1   0 undefined     https://example.com

I inspected URLs of both the production domain (https) and a staging sub-domain (http) on the same server (with identical html, needless to say). The LinkedIn scraper is able to fetch all metadata from the http sub-domain but not the https domain which leads me to believe the problem might be related to SSL authentication between the site and LinkedIn.

Has anyone else encountered this problem and can either confirm my suspicion or point me in a direction?

As a sidenote, both the facebook share debugger and the twitter card validator are able to fetch all metadata on all of the tested URLs via both protocols.

Ronald Werkhoven asked the same question here: Validating link in post-inspector linkedin in gives server error Checking the URL he provided in the LinkedIn post inspector does not throw any errors, so apparently he was able to fix the problem. Would you, Ronald, mind sharing how you were able to resolve the issue?

2 Answers

one thing i know is that linkedin has crawler issues with the crawlers they use for og. i do not know if they use those crawlers with the post inspector aswell. but that could definitly cause such a issue if they did.

beneath i quoted the response of the linkedin team. so i do not know if there will be a fix anytime soon if these problems are related.

Thanks for reporting your issue. We've confirmed the problem you reported. After careful assessment, we've decided that we won't be moving forward with a fix at this time. LinkedIn continuously evaluates how features and products are used and we make adjustments accordingly to focus our resources on providing the most value to our members.

We greatly appreciate your feedback and have documented the issue to track additional reports of the problem and for consideration to be addressed in a future release. If there's anything else I can help you with, please don't hesitate to let me know.

For the benefit of other people coming from Google, I was having this problem on my website as well, but for me the problem was HTML-minification related.

Linkedin doesn't parse the short doctype <!doctypehtml> so you'll probably get a 500 server error if this is in your page.

Related