I've set up a Google Maps Static API and added my API key to my code. It still comes up with an error. 403 forbidden, g.co/staticmaperror/signature
I have set the http referrer to be MYDOMAIN.COM/* and also *.MYDOMAIN.COM/*
I can't get it to stop showing a 403 error. I've only just set up the static map so it can't be a quota issue. The same code works on another client site (different domain, http referrer and API key).
I've recreated the API key and double checked it has copied and pasted correctly. I've spell checked my http referrer.
Is there any other reason I could be blocked from using the Static map API?