Postgresql warning: "could not flush dirty data: Function not implemented"

Viewed 13801

I'm trying to create a new database on postgres, by running command:

CREATE DATABASE dbname;

and I face the error:

WARNING: could not flush dirty data: Function not implemented

many times! and finally I get the message

CREATE DATABASE

Can anyone help me to undrestand and solve this error please?

3 Answers

I solved the problem by updating postgresql.conf file. Add the following codes at the end of /etc/postgresql/11/main/postgresql.conf.

fsync = off
data_sync_retry = true

(Corrected underscores)

Restarting the postgres sql did the trick for me

Use the following command

sudo service postgresql restart
Related