I installed Docker on Windows 10 with Hyper-V. And the virtual network interface named vEthernet(DockerNAT) is generated. Below are network interfaces of my Windows 10 computer.
> ipconfig
Windows IP Configuration
Ethernet adapter vEthernet (DockerNAT):
Connection-specific DNS Suffix.:
Link-local IPv6 Adress . . . . : fe80::a9a7:f59e:48dc:ff5f%14
IPv4 Address . . . . . . . . . : 10.0.75.1
Subnet Mask . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . :
Ethernet adapter Ethernet0:
Connection-specific DNS Suffix. :
Link-local IPv6 Address . . . . : fe80::1091:20e7:135a:3e3f%2
IPv4 Addres. . . . . . . . . . : 192.168.200.51
Subnet Mask . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . : 192.168.200.2
The problem is that vEthernet (DockerNAT) not be connected to my external IP of Ethernet0. I try to make vEthernet (DockerNAT) connected to external Ethernet0 with Hyper-v manager. But not working. In the same case of CentOS 7 one command solves this issue.
> ifconfig
docker0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 192.168.1.1 netmask 255.255.255.0 broadcast 0.0.0.0
ether 02:42:be:b3:0c:4c txqueuelen 0 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
ens33: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.200.51 netmask 255.255.255.0 broadcast 192.168.200.255
inet6 fe80::66f:c6c7:d994:e992 prefixlen 64 scopeid 0x20<link>
ether 00:0c:29:57:00:09 txqueuelen 1000 (Ethernet)
RX packets 34 bytes 5821 (5.6 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 58 bytes 7677 (7.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
I used iptables command of Centos 7 to let docker0 accept packets
> iptables -I INPUT 1 -i docker0 -j ACCEPT
Is there a similar functional command or process on Windows 10 to configure DockerNAT connection?