I'm running a Debian Wheezy server in GCE. We have Docker containers using the AUFS storage driver. Something changed recently, and today I am unable to connect to the docker daemon.
Example output from running
docker daemon --storage-driver=aufs
FATA[0001] Error starting daemon: error initializing graphdriver: driver not supported
All the other answers to this question are either a) rm -rf /var/lib/docker/aufs, ie start completely over or b) --storage-driver=overlay2, run with a different storage driver. However I do not want to lose my containers, and I haven't found a way to export them without the daemon running with the aufs storage driver.
I've been all over the internet looking up solutions. The official docs (https://docs.docker.com/engine/userguide/storagedriver/aufs-driver/#configure-docker-with-the-aufs-storage-driver) say my Debian version is supported (7.12) and my kernel version is supported (3.16.0-0.bpo.4-amd64).
If I run the daemon with storage-driver=devicemapper docker connects as expected, however of course none of my containers are there as they are in the AUFS system.
When I run /proc/filesystems | grep aufs the result is blank, however aufs is present as a module at /lib/modules/3.16.0-0.bpo.4-amd64/kernel/fs/aufs/aufs.ko.
From the docker site I downloaded and ran the script here: https://raw.githubusercontent.com/docker/docker/master/contrib/check-config.sh
The output includes:
CONFIG_AUFS_FS: enabled (as module)
Other advice I've come across uses modprobe, when I do sudo modprobe aufs I get the error
ERROR: could not insert 'aufs': Unknown symbol in module, or unknown parameter (see dmesg)
and then dmesg | grep aufs shows this error line:
aufs: Unknown symbol setfl (err 0)
From there I ran modinfo aufs and got this block of output, which I frankly don't know what to do with:
filename: /lib/modules/3.16.0-0.bpo.4-amd64/kernel/fs/aufs/aufs.ko
staging: Y
alias: fs-aufs
version: 3.16-20140908+setfl
description: aufs -- Advanced multi layered unification filesystem
author: Junjiro R. Okajima
license: GPL
srcversion: 986E0DDDAA9BDCB0E005DF4
depends:
intree: Y
vermagic: 3.16.0-0.bpo.4-amd64 SMP mod_unload modversions
parm: brs:use /fs/aufs/si_*/brN (int)
parm: allow_userns:allow unprivileged to mount under userns (bool)
I'm at a loss how to proceed, I can't really tell if the error is with docker itself or with the aufs dependency. I also do not know what could have changed in the last day or so to make my system change behavior. I know I'm a few version behind on some of the software, what can I safely upgrade to get docker working with aufs again? Or what else can I try?