I had a 12TB ext4 partition which I wanted to extend to 18TB. I've added the new disks to the RAID and after doing that I wanted to re-size the partition to occupy this new space. I started the growth of the partition but the procedure failed because the ext4 cannot handle partitions bigger than 16TB.
The problem is that now when I open gparted, gparted shows that the size of the partition is 18TB but I can see only 12TB in Nautilus window.
How can I roll back the effects of the gparted operation so the two sizes are consistent with each other?
# resize2fs /dev/sda1
resize2fs 1.42.5 (29-Jul-2012)
resize2fs: New size too large to be expressed in 32 bits