ESXi host won't power on, in current state (powerd off)

Viewed 36993

I had this working Windows Server 2012 VM, that needed a reboot. After I rebooted the vm, changed some settings (attached a dvd drive), it would boot up again.

Now it says:

Failed - The attempted operation cannot be performed in the current state (Powered off).

I can't revert the setting, because of this state, I checked the host machine, tried booting it from there, but no luck. Also tried to reboot, reset, etc but nothing worked, it is not in the running VMs list.

2 Answers

I had the same error on a Ubuntu VM fresh installed. Solved without rebooting ESXi. just unregister and register back the VM. Hope this help.

Related