I am new to kubernetes and have started building a cluster on RHEL 7.3. I have kubernetes cluster setup on the master. When i try to use
kubeadm join --token ancdbs.askdcvasdckasd x.x.x.:6443
the node is not able to join with following error message:
[discovery] Trying to connect to API Server "10.26.24.37:6443"
[discovery] Created cluster-info discovery client, requesting info from "https://10.26.24.37:6443"
[discovery] Failed to connect to API Server "10.26.24.37:6443": there is no JWS signed token in the cluster-info ConfigMap. This token id "a7d815" is invalid for this cluster, can't connect
Did notice this being listed as an issue in version 1.7 I am currently on versions shown below.
Kubeadm version node:
kubeadm version: &version.Info{Major:"1", Minor:"7", GitVersion:"v1.7.0",
GitCommit:"d3ada0119e776222f11ec7945e6d860061339aad", GitTreeState:"clean",
BuildDate:"2017-06-29T22:55:19Z", GoVersion:"go1.8.3", Compiler:"gc",
Platform:"linux/amd64"}
Kubeadm version master:
kubeadm version: &version.Info{Major:"1", Minor:"7", GitVersion:"v1.7.0",
GitCommit:"d3ada0119e776222f11ec7945e6d860061339aad", GitTreeState:"clean",
BuildDate:"2017-06-29T22:55:19Z", GoVersion:"go1.8.3", Compiler:"gc",
Platform:"linux/amd64"}
I also have seen some mention about workarounds...would like to know.
How the work around can be implemeted, if possible.