WAMP MySQL will not start now after having unsolved password issues

Viewed 215

Prologue

First I want to mention that the original issue was password related. I kept getting wrong password error in both phpmyadmin and mysql console. I did not change the password to be clear.

Attempted solutions:

  1. Restarting services
  2. Rebooting PC
  3. Tried possible default passwords: root, password, 'blank', your_password
  4. Inserted ALTER USER 'root'@'localhost' IDENTIFIED BY 'MyNewPass'; into the first line of file "my.ini", which actually came from here https://dev.mysql.com/doc/refman/5.7/en/resetting-permissions.html

New issue

After attempt number 4, the server now sefuses to run, wampmysql64 is stuck on starting in windows services. Rolling back the changes did not solve it.

Attempted solutions(again)

  1. Restarting services
  2. Rebooting PC
  3. Turning off firewall
  4. Port 3306 is not being used by any other service or process.
  5. Made sure 'skip-networking' was commented in my.ini
  6. Deleting auto.cnf, and ib_logfile0 and ib_logfile1

All failed. Attempts 5 and 6 came from here https://superuser.com/questions/321744/wamp-mysql-service-will-not-start

MySQL files

my.ini

mysql.log

UPDATE

  • inside wampmysql64 properties in services
  • general tab
  • startup type was set to disabled
  • changing it back to manual gave error "service marked for deletion"

After a reboot

  • wampmysql64 service is gone
  • reinstalling it through the wamp menu>mysql>service administration
  • It runs now!

Password Anomaly remains.

UPDATE 2

Password was successfully reset with this code into mysql console, I had to run the server with skip-grant-tables uncommented(byremoving the ';') from the my.ini file.

UPDATE mysql.user
SET authentication_string = PASSWORD('MyNewPass'), password_expired = 'N'
WHERE User = 'root' AND Host = 'localhost';
FLUSH PRIVILEGES;

Reboot, Restart all servives, bingo, connected and password is working. Wait what?......Databases are gone.

0 Answers
Related