I am attempting to put a CloudFront Distribution in front of a Yum (RPM) repo which uses basic http authentication. I've setup the CloudFront Distribution w/ HTTPS, redirection from HTTP to HTTPS, with the following values:
Origin: yum.mydomain.com
Origin ID: smp-yum.mydomain.com
Note: smp-yum.mydomain.com does not exist right now, I am not sure if it needs to?
For testing purposes I am strictly using the abcdefgh.cloudfront.net domain.
I am getting the following error trying to visit the URL:
CloudFront attempted to establish a connection with the origin, but either the attempt failed or the origin closed the connection.
Because I know the host is up, and accepts connections from the public internet, I can only assume that it is due to the http basic auth.
I have also attempted to include the credentials into the request, via
https://username:password@yum.mydomain.com/repo/url
I suppose this is a two-part question: Is it possible to use HTTP Basic Auth? and if so, is there some headers or something that I need to customize in order to make it work?