Creating MyISAM Table in Azure database for MySQL is enable?

Viewed 3919

When I create table that engine is MyISAM in Azure database for Mysql, Got Error "ERROR 1030 (HY000): Got error 1 from storage engine"

How do I fix it? or can I use MyISAM table in Azure database for MySQL?

cli screen captuer

3 Answers

So I had the same issue but getting this error on my local mysql database. I would suggest that the first thing you do is check the storage engine.

In my case it turned out that the storage engine was ARCHIVE and changing this to InnoDB solved the issue.

Related