Neo4j server fails to start with unmanaged extension

Viewed 470

I'm trying to use unmanaged extensions on a neo4j server (version CE 2.3.2), so I'm trying a simple HelloWorld example given on the official Neo4j website:

  • I've generated the jar file with the "org.neo4j.server.plugins.ServerPlugin" file in the "METADATA/services" folder.
  • I put my jar in the "[neo4jInstallPath]/plugins" folder
  • I put the following line in the "C:\Users[currentUser]\AppData\Roaming\Neo4j Community Edition\neo4j-server.properties"

    org.neo4j.server.thirdparty_jaxrs_classes=org.neo4j.examples.server.unmanaged=/examples/unmanaged

But when I try to start my Neo4j server, it crashes with the following error:

Starting Neo4j failed: org.neo4j.server.web.NeoServletContainer-ff3335e@3ada3fcf==org.neo4j.server.web.NeoServletContainer,-1,false

I've tried several things such as moving the "org.neo4j.server.plugins.ServerPlugin" in some other places, I've tried others Helloworld examples, etc... but I always get the same error when launching the server does somebody knows what to do?

Thanks.

1 Answers
Related