Cannot bind arango 2.8.5 to to endpoint ssl://0.0.0.0:443

Viewed 292

I am using arangodb 2.8.5 on ubuntu 14.04 (64bit)

  • In config file, endpoint = ssl://0.0.0.0:443
  • fails to start with error msg in log "FATAL failed to bind to endpoint 'ssl://0.0.0.0:443'. Please check whether another instance is already running or review your endpoints configuration."
  • Ran netstat -lnpt. Only port 22 is in use by ssh

    Server starts up and binds to port 8530 with ssl when using endpoint = ssl://0.0.0.0:8530. Admin website is accessible https://www.website.com:8530/.../

    I want the admin ui to be accessible without the need for additional port 8530 i.e. https://www.website.com/. This was possible to set up in the earlier versions. What am i doing wrong or is this not possible anymore?

Small application so i am trying to avoid running another web server in front to forward requests to arango apps. Thank you very much for any direction.

Regards, Anjan

1 Answers
Related