How to share Data disk among many virtual machines running Linux in Azure?

Viewed 2736

I have my virtual machine running Linux. I've created it via new "Resource manager". Then I added data disk to it.

Then I created new Virtual Machine. And I want it to use the same data disk attached to the first one (at least in read-only mode).

When I try to "attach existing disk" to this new machine I get this error: Failed to attach existing disk 'DISK-NAME.vhd' to the virtual machine 'MACHINE-NAME'. Error: Failed to acquire lease while creating disk 'DISK-NAME.vhd' using blob with URI https://BLOB-URI-disk1.vhd. Blob is already in use.

How do I attach existing data disk which is in use by another machine to my current machine?

3 Answers
Related