TFS 2012 - Scheduled Backups Failing

Viewed 2964

I'm trying to setup Nightly Backups for my TFS 2012.4 development box going off to another server, but it's failing.

The server is has SQL Express and TFS Express on it, trying to send the backups over to a network path on another share.

When going through the Wizard it will successfully pass all of the Readiness Checks, including permissions. It will fail when it tries to run the backup job for the first time under Confirming Permissions.

Error is:

TF401002: The SQL Server Database Engine failed to save the database backup to path \[share]\c$\TFSBackup. Please grant SQL service account read/write access to that folder.

I've tried adding "Everyone" with full control to the folder on the backup server, but it still fails with the same error.

Added the full log to http://pastebin.com/80PrYXqx

2 Answers
Related